<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" prefix="og: http://ogp.me/ns#">
<head><title>Chap Mei Dinosaurs | Dinosaur Home</title>
<meta name="robots" content="index, follow"/>
<script type="text/javascript">var isStyleNormal=1</script>
<style media='all'>.post-meta-data .post-meta-data-date,.post-meta-data .userEdit,.post-meta-data .vote_block_all{display:inline;margin-right:.75em}.post-entry,.commentlist.undecorated,#mojo-main .moduletable_simple_title{margin-bottom:3em}.commentlist.undecorated{padding-left:1.5em}.post-entry span[style*="font-size: small;"]{font-size:1em!important}.comment img,.post-entry img{height:auto!important;width:initial!important}.post-entry img:not(.zoomable):not([src$="/rt_fire/images/cc.png"]):not(.cc_license){display:block}span.cc_license,div.cc_license{display:block;font-size:.85em;font-style:italic;padding-left:.5em;margin-bottom:1.5em}.t-style-rt .blog-user-snippet{font-style:italic;padding:1.5em .75em;border-style:solid none}.t-style-rt .blog-comment-request{display:inline}#mojo_comments form p{margin-bottom:.4em}#mojo_comments label[for="author"],#mojo_comments label[for="email"],#mojo_comments label[for="url"]{display:block}#mojo_comments input[type="text"],#mojo_comments input[type="email"]{max-width:60%}.sticky-top-bar-on .commentlist .link-target{padding-top:.25em}.commentlist .comment-block{margin-bottom:1.5em}.commentlist .comment{display:block}.commentlist .comment p{margin-bottom:0}#mojo-main .navigation{margin-bottom:1.5em;text-align:center;font-weight:bold}p video{float:left;margin:.25em 1.5em .25em 0;padding:0;max-width:100%;max-height:30em}p.ugc-video-container{position:relative;padding-bottom:56.25%;padding-top:1.875em;height:0;overflow:hidden}p.ugc-video-container iframe,p.ugc-video-container object,p.ugc-video-container embed{position:absolute;top:0;left:0;width:100%;height:100%}#overDiv .commnets-share{margin-left:-8em}</style>
<style media='all'>.share-bar-placeholder{margin-bottom:1.5em;margin-top:-.5em}.share-bar-holder{padding-top:.5em;padding-bottom:.45em}.sticky-top-bar-on .share-bar-holder{position:fixed;left:0;right:0;top:0;width:100%;background-color:#fff;border-bottom-style:solid;border-bottom-width:1px;box-shadow:0 2px 5px 0 rgba(0,0,0,.26);z-index:99999}.sticky-top-bar-on.user-zoomin .share-bar-holder{display:none}.share-bar .button-small{background-image:none;border:none;color:#fff;font-size:1em;margin-left:.25em;min-width:1.5em;user-select:none;-webkit-tap-highlight-color:rgba(0,0,0,0);tap-highlight-color:rgba(0,0,0,0)}.share-bar .hits{display:inline-block;margin-right:.5em;margin-top:-.0625em;font-size:1.25em;line-height:1.1;text-align:center;vertical-align:top}.share-bar .hits:after{content:"views";display:block;font-size:.6em}.share-bar-holder .share-bar .hits{float:left}.share-bar .w-text:after{font-family:Arial;font-size:.875em;padding-left:.25em;vertical-align:text-bottom}.share-bar .button-small:hover{background-image:none;color:#fff}.share-bar .icon-twitter{background-color:hsl(196,100%,46%)!important}.share-bar .icon-facebook{background-color:#3b5998!important}.share-bar .drop-wrap[share-url] .drop-control{vertical-align:top;background-color:#aaa!important;padding:.52em}.share-bar .iconx-googleplus{background-color:#dd4b34!important}.share-bar .share-pinterest{display:none}.share-bar .iconx-wordpress{background-color:#1e8cbe!important}.share-bar .icon-envelope,.share-bar .iconx-envelope,.share-bar .iconx-printer,.share-bar .iconx-files-empty{background-color:#777!important}.share-bar .iconx-whatsapp{background-color:#61be4f!important}.share-bar .icon-twitter.w-text:after{content:"share on twitter"}.share-bar .icon-facebook.w-text:after{content:"share on facebook"}.share-bar .drop-wrap[share-url] .share-facebook,.share-bar .drop-wrap[share-url] .share-twitter{display:none}.share-bar-holder .bar-title{display:none;max-width:0;overflow:hidden;height:1.2em;font-size:1.2em;line-height:1.2;margin-top:-.2em;vertical-align:middle;text-transform:capitalize;transition:margin .1s ease , max-width .2s linear;margin-right:1em}.share-bar{display:inline-block;position:relative}.share-bar .drop-wrap.drop-wrap[share-url]{position:static}.share-bar .drop-wrap[share-url] .drop-area{white-space:nowrap;right:-.125em;padding:.5em .375em}.share-bar .drop-wrap[share-url] .drop-area .button-small{padding:.535em;margin:0 .25em;line-height:.95}.sticky-top-bar-on .link-target,.sticky-top-bar-on a:empty[name]{display:block;position:relative;top:-3em;visibility:hidden}.sticky-top-bar-on .share-bar-holder .hits-full{display:none}.sticky-top-bar-on .share-bar-holder .hits-minimal{display:inline}.sticky-top-bar-on .share-bar-holder .bar-title{display:inline-block}.sticky-top-bar-on.share-bar-title-open .share-bar-holder .bar-title{max-width:37em;margin-left:0!important}.sticky-top-bar-on .share-bar-holder .icon-twitter.w-text:after{content:"tweet"}.sticky-top-bar-on .share-bar-holder .icon-facebook.w-text:after{content:"share"}@media (max-width:69.9999em){.share-bar-holder .share-bar .icon-twitter.w-text:after{content:"tweet"}.share-bar-holder .share-bar .icon-facebook.w-text:after{content:"share"}body:not(.sticky-top-bar-on) .share-bar-holder .share-bar .drop-wrap[share-url] .drop-area {right:inherit;left:-.325em}.sticky-top-bar-on .share-bar-holder .bar-title{font-size:1.1em}.sticky-top-bar-on.share-bar-title-open .share-bar-holder .bar-title{max-width:calc(100% - 16.5em)}}@media (max-width:42.4999em){.sticky-top-bar-on .share-bar-holder .bar-title{display:none}.sticky-top-bar-on .share-bar-holder .share-bar .drop-wrap[share-url] .drop-area{right:inherit;left:-.325em}.sticky-top-bar-on .share-bar-holder .hits-full{display:inline}.sticky-top-bar-on .share-bar-holder .hits-minimal{display:none}.sticky-top-bar-on .share-bar-holder .share-bar .hits{float:left}}@media (max-width:23.9999em){.share-bar{margin-right:-.5em}.share-bar .button-small{margin-left:.25em}.share-bar .hits{margin-right:.25em}}@media (max-width:20.9999em){.share-bar .w-text:after,.sticky-top-bar-on .share-bar-holder .share-bar .w-text:after{content:none!important}.share-bar{position:inherit}.share-bar .drop-wrap[share-url] .drop-area{left:calc(50% - 9.15em)!important}.share-bar .drop-wrap[share-url] .drop-area .button-small{padding-left:.45em;padding-right:.45em}}</style>
<script type="text/javascript">var shareOptions={"disableSticky":false,"twitterAccount":"dnsrhome"}</script>
<style media='all'>html{margin:0;padding:0;border:0;font-family:arial;-webkit-text-size-adjust:none}.reset-fonts{font-family:arial;font-weight:normal}body,div,span,object,iframe,h1,h2,h3,h4,h5,h6,p,blockquote,pre,a,abbr,acronym,address,code,del,dfn,em,img,q,dl,dt,dd,ol,ul,li,fieldset,form,label,legend,table,caption,tbody,tfoot,thead,tr,th,td,article,aside,dialog,figure,footer,header,hgroup,nav,section{margin:0;padding:0;border-style:none;border-color:#ddd;border-width:.0625em;font-size:100%;font:inherit;vertical-align:baseline}input,select,textarea{border-width:.07em}article,aside,details,figcaption,figure,dialog,footer,header,hgroup,menu,nav,section{display:block}body{line-height:1.5;color:#222}table{border-collapse:separate;border-spacing:0}table[cellpadding="0"]>tr>td,table[cellpadding="0"]>tr>th,table[cellpadding="0"]>tbody>tr>td,table[cellpadding="0"]>tbody>tr>th{padding:0}caption,th,td{text-align:left;font-weight:normal;float:none!important}table,th,td{vertical-align:middle}table.valign-top th,table.valign-top td{vertical-align:top}blockquote:before,blockquote:after,q:before,q:after{content:''}blockquote,q{quotes:"" ""}.uddeim-replyquote,blockquote,q{border-left:solid .25em;padding:.5em 0 .5em 1.5em;opacity:.7;font-style:italic;margin:.25em 0 1.5em}blockquote>p:last-child,q>p:last-child{margin-bottom:0}img{max-width:100%}a img{border:none}:focus{outline:0}ul>br,ol>br,p+br,ul+br,ol+br,li+br,blockquote+br,q+br{display:none}em{font-style:italic}p:empty,form:empty{margin:0;padding:0}input.text,input.title{width:25em}input[type="checkbox"]{margin:.5em .2em .5em .5em}input[type="checkbox"],input[type="radio"]{cursor:pointer}input[type="text"],input[type="password"],input[type="url"],input[type="file"],input[type="date"],input[type="datetime"],input[type="email"],input[type="search"],input.text,input.title,textarea,select{width:92%;width:-moz-calc(100% - 1.1em);width:-webkit-calc(100% - 1.1em);width:-o-calc(100% - 1.1em);width:calc(100% - 1.1em);margin:0 0 .25em;font-family:Verdana,sans-serif;font-size:1em;background-color:#fff;color:#222;padding:.5em;border-style:solid}textarea{padding:.25em .5em}form,input,select,textarea,.attach-images-in-textarea-block .attach-images-in-textarea-label{border-color:#e8e8e8}input[type="text"]:focus,input[type="password"]:focus,input[type="url"]:focus,input[type="file"]:focus,input[type="date"]:focus,input[type="datetime"]:focus,input[type="email"]:focus,input[type="search"]:focus,input[type="file"]:focus,input.text:focus,input.title:focus,textarea:focus,.attach-images-in-textarea-block.focus .attach-images-in-textarea-label{border-color:#aaa}input[readonly="readonly"]{background:#ccc}select{width:100%}br+input[type="text"],br+input[type="password"],br+input[type="url"],br+input[type="file"],br+input[type="date"],br+input[type="datetime"],br+input[type="email"],br+input[type="search"],br+input.text,br+input.title,br+textarea,br+select{margin-left:0;margin-right:0}select{padding-top:.425em;padding-bottom:.425em}textarea{height:21em;overflow:auto;line-height:1.5;display:block}.input-right-protect{margin-right:1.1em}input[type="search"]{-webkit-appearance:none}:invalid{outline:none;box-shadow:none}h1,h2,h3,h4,h5,h6{font-weight:normal;word-wrap:break-word}h1,h2{text-transform:capitalize;font-family:'Helvetica Neue',Helvetica,Arial,sans-serif}h1 a{text-decoration:none}h1 a:hover{text-decoration:underline}h3 strong,h3 em,h3 b{font-weight:normal}li ul,li ol,ul ul ul ol,ol ol,ol ul{margin:.5em 0 0 0}ul,ol{margin:1.5em 1.5em 1.5em 0;padding-left:1.5em}li{margin-bottom:.5em}ul{list-style-type:disc}ol{list-style-type:decimal}dl{margin:0 0 1.5em 0}dl dt{font-weight:bold}dd{margin-left:1.5em}p{margin-bottom:1.5em}p,table,ul,ol{word-wrap:break-word}table{margin-bottom:1.5em}th{font-weight:bold}th,td,caption{padding:.25em .5em .25em .25em}th.no-pad,td.no-pad,caption.no-pad{padding:0}h3+ul,h5+ul,li+ul{margin-top:0}h3+ul li,h5+ul li{margin-bottom:.25em}.error ul{margin-top:.75em;margin-bottom:.75em}.error li{margin-bottom:.25em}:-ms-input-placeholder{color:#888!important}</style>
<style media='all'>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</style>
<style media='all'>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</style>
<style media='all'>body{background:hsl(101,22%,98%)}a{color:hsl(348,93%,28%)}a:visited:not(.control):not(.text-color):not(.button):not(.button-small):not(:hover) {color:hsl(348,17%,59%)}a:hover:not(.button):not(.text-color):not(.button-small),
a:active:not(.button):not(.text-color):not(.button-small),
a:focus:not(.button):not(.text-color):not(.button-small) {color:hsl(348,92%,42%)}div,h1,h2{border-color:hsl(101,22%,85%)}#main-top,.moduletable_search input[type="submit"]{background:hsl(101,75%,13%)}#main-top .logo-link,#main-top .link-icon.dark{color:hsl(69,56%,54%)!important}.moduletable_search form:after{background-color:hsl(69,56%,54%)!important}#main-body form input[type=submit]:not(.moderate_full):not(.moderate),
.cb-tips-font input[type=submit]:not(.moderate_full):not(.moderate),
.button-yellow {background-color:hsl(69,35%,46%);background-image:-webkit-linear-gradient(top,hsl(69,35%,51%),hsl(69,35%,46%));background-image:-moz-linear-gradient(top,hsl(69,35%,51%),hsl(69,35%,46%));background-image:-o-linear-gradient(top,hsl(69,35%,51%),hsl(69,35%,46%));background-image:linear-gradient(top,hsl(69,35%,51%),hsl(69,35%,46%));color:#fff;border-color:hsl(69,35%,46%)}#main-body form input[type=submit]:active:not(.moderate_full):not(.moderate),
#main-body form input[type=submit]:hover:not(.moderate_full):not(.moderate),
#main-body form input[type=submit]:focus:not(.moderate_full):not(.moderate),
.cb-tips-font input[type=submit]:active:not(.moderate_full):not(.moderate),
.cb-tips-font input[type=submit]:hover:not(.moderate_full):not(.moderate),
.cb-tips-font input[type=submit]:focus:not(.moderate_full):not(.moderate),
.button-yellow:active,
.button-yellow:hover,
.button-yellow:focus {background-color:hsl(69,45%,46%);background-image:-webkit-linear-gradient(top,hsl(69,45%,51%),hsl(69,45%,46%));background-image:-moz-linear-gradient(top,hsl(69,45%,51%),hsl(69,45%,46%));background-image:-o-linear-gradient(top,hsl(69,45%,51%),hsl(69,45%,46%));background-image:linear-gradient(top,hsl(69,45%,51%),hsl(69,45%,46%));color:#fff;border-color:hsl(69,45%,46%)}.testimonial_full{background:hsl(101,27%,99%)}.cb-tips-bg,.cb-tips-capfont{background:hsl(101,12%,73%)}</style>
<style media='all'>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</style>
<link type='text/css' rel='stylesheet' media='print' href='https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/css/A.tcss_print_v_1512828417.css.pagespeed.cf.M4QWDqDuMy.css'/>
<style media='all'>@font-face{font-family:'icomoon';src:url(data:application/font-woff;charset=utf-8;base64,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) format('woff');font-weight:normal;font-style:normal}[class^="icon-"],[class*=" icon-"]{font-family:'icomoon'}.icon-search:before{content:"\ea5a"}.icon-folder-open:before{content:"\e9b8"}.icon-pen5:before{content:"\e919"}.icon-enter:before{content:"\eb97"}.icon-twitter:before{content:"\ec62"}.icon-facebook:before{content:"\ec5c"}.icon-redo2:before{content:"\ea3a"}</style>
<meta property='fb:app_id' content='125601500980986'/>
<meta property='fb:admins' content='100000935103753'/>
<meta property='og:site_name' content='Dinosaur Home'/>
<meta property='og:title' content='Chap Mei Dinosaurs'/>
<meta property='og:url' content='https://www.dinosaurhome.com/chap-mei-dinosaurs-14768.html'/>
<meta property='og:type' content='article'/>
<meta property='article:author' content='https://www.dinosaurhome.com/members/carnoferox/'/>
<meta property='article:published_time' content='2017-02-07T17:57:53-07:00'/>
<meta property='article:modified_time' content='2017-02-09T15:15:06-07:00'/>
<meta property='article:publisher' content='https://www.facebook.com/Dinosaur-Home-501027070024082/'/>
<meta property='og:image' content='https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6580-1wysr6ext9.jpg'/>
<meta property='og:image:width' content='1280'/>
<meta property='og:image:height' content='960'/>
<meta property='og:description' content='Chap Mei is a Hong Kong toy company that has produced numerous series of dinosaur toys over the years. I happen to own quite a few Chap Mei dinosaurs, and I thought that I would share photos of some of my collection. Although these came in sets with human  ...'/>
<meta name='twitter:card' content='summary_large_image'/>
<meta name='twitter:site' content='@dnsrhome'/>
<meta name='twitter:via' content='dnsrhome'/>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.dinosaurhome.com\/chap-mei-dinosaurs-14768.html"},"url":"https:\/\/www.dinosaurhome.com\/chap-mei-dinosaurs-14768.html","headline":"Chap Mei Dinosaurs","image":{"@type":"ImageObject","url":"https:\/\/d29jd5m3t61t9.cloudfront.net\/dinosaurhome.com\/components\/com_mojo\/wp-content\/uploads\/2017\/02\/IMG_6580-1wysr6ext9.jpg","height":960,"width":1280},"datePublished":"2017-02-07T17:57:53-07:00","dateModified":"2017-02-09T15:15:06-07:00","author":{"@type":"Person","name":"Carnoferox","url":"https:\/\/www.dinosaurhome.com\/members\/carnoferox\/","description":"I am fascinated with dinosaurs and am eager to discuss them with anyone. I love theropods and the spinosaurs in particular. My favorite dinosaurs are Spinosaurus aegyptiacus, Ankylosaurus magniventris, and Alioramus remotus. My favorite paleontologists ...","image":{"@type":"ImageObject","url":"https:\/\/d29jd5m3t61t9.cloudfront.net\/dinosaurhome.com\/images\/comprofiler\/1780-n01y29cikv.png","height":1024,"width":1024}},"publisher":{"@type":"Organization","name":"Dinosaur Home","logo":{"@type":"ImageObject","url":"https:\/\/d29jd5m3t61t9.cloudfront.net\/static\/images\/logo\/dinosaurhome.com.png","width":285,"height":33}},"description":"Chap Mei is a Hong Kong toy company that has produced numerous series of dinosaur toys over the years. I happen to own quite a few Chap Mei dinosaurs, and I thought that I would share photos of some of my collection. Although these came in sets with human  ..."}</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-57x57_v_1501069202.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-60x60_v_1501069168.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-72x72_v_1501069207.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-76x76_v_1501069169.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-114x114_v_1501069190.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-120x120_v_1501069172.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-144x144_v_1501069206.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-152x152_v_1501069186.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/apple-touch-icon-180x180_v_1501069198.png">
<link rel="icon" type="image/png" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/favicon-32x32_v_1501069180.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/android-chrome-192x192_v_1501069170.png" sizes="192x192">
<link rel="icon" type="image/png" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/favicon-96x96_v_1501069176.png" sizes="96x96">
<link rel="icon" type="image/png" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/favicon-64x64_v_1501069201.png" sizes="64x64">
<link rel="icon" type="image/png" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/favicon-24x24_v_1501069186.png" sizes="24x24">
<link rel="icon" type="image/png" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/favicon-16x16_v_1501069181.png" sizes="16x16">
<link rel="shortcut icon" href="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/military/favicon_v_1501069213.ico">
<meta name="msapplication-TileColor" content="#1C4780">
<meta name="msapplication-TileImage" content="https://d29jd5m3t61t9.cloudfront.net/static/images/icons/default/mstile-144x144_v_1501069182.png">
<meta name="theme-color" content="#ffffff">
<link rel="manifest" href="/manifest.dinosaurhome.com_v_1517487167.json">
<meta name="msapplication-config" content="https://d29jd5m3t61t9.cloudfront.net/static/browserconfig_v_1501069199.xml">
<meta name="viewport" content="initial-scale=1.0"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta http-equiv="Content-Language" content="en"/></head>
<body class="user-guest t-style-normal forestfire">
<script type="text/javascript">function setBarOnHashlink(){if(window.location.hash&&window.performance&&window.performance.navigation.type==0)document.body.className+=" sticky-top-bar-on share-bar-title-open";}setBarOnHashlink();</script><script type="text/javascript">(function(b,c,d){var f=c.documentElement,a=d.userAgent,g=function(){return 430>=f.clientWidth},e=function(){return a.match(/iPhone|iPad|iPod/i)};c.body.className+=(e()?" ios":"")+(a.match(/Android/i)?" android":"");d.standalone=d.standalone||a.match(/Android/i)&&40>screen.height-f.clientHeight||b.matchMedia("(display-mode: standalone)").matches;b.isMobile=g;b.isTablet=function(){return!g()&&(e()||a.match(/Android/i)||a.match(/iemobile|Windows Phone/i))};b.isIOS=e})(window,document,navigator);</script>	<div id="main-top" class="space-page-top">
<div class="wrapper">
<div class="main-top-sizer">
<div id="header"><div>
<a href="/" class="logo-link control"><span class="logo "><span class="word">D<span class="logo-chars-compacting">inosaur</span></span> <span class="word">H<span class="logo-chars-compacting">ome</span></span></span></a>
<span class="for-print view-current-url x-smaller"></span>
</div>
<span class="for-print qr-code"></span>
</div>
<div id="rheader">	<div class="moduletable_search">
<form action="search.html" id="main_search_form" onsubmit="return searchClick(this);">
<input name="search_req" value=search type="hidden"/>
<input name="searchword" id="search_word_input" maxlength="100" alt="search" class="inputbox_search rounded_corners_lp" type="search" value="" onblur="return searchBlur();" onclick="return searchTextClick();"/>
<input type="submit" value="&nbsp;" class="button" id="main_search_button"/>
</form>
<div class="clr"></div>	</div>
<div class="moduletable_icons_menu">
<div id="usermenu-icons"><a class="link-icon um-item um-me um-me-signin" href="members/sign-in.html" title="Sign in / Sign up"><span class="font-icon icon-enter"></span><span class="link-icon-data">Sign in</span></a><a class="link-icon um-item um-browse" href="forums/" title="Browse our categories"><span class="font-icon icon-folder-open"></span><span class="link-icon-data">Browse</span></a><span class="link-icon um-item um-search" onclick="mainSearchClick();" title="Search our site"><span class="font-icon icon-search"></span><span class="link-icon-data">Search</span></span><a class="link-icon um-item um-new dark" href="questions-answers/ask.html" title="Ask a new question"><span class="font-icon icon-pen5"></span><span class="link-icon-data">Ask</span></a></div>	</div>
</div>
<div class="clr"></div>
</div>
</div>
</div>
<div id="main-body">
<div class="wrapper">
<div id="body-top"></div>
<div id="middle-col">
<div class="padding">
<div id="top"></div>
<div id="mojo-main" class="single">
<div id="mojo-post-14768" class="post">
<div class="mojo_header">
<h1>
Chap Mei Dinosaurs	</h1>
<div class="post-meta-data quiet">
<span>
by
<a href="members/carnoferox/">Carnoferox</a></span>
<span class="post-meta-data-date post-meta-data-no-sap nowrap"><span title='Feb 7, 2017'>1<span class="hide-on-nt-480"> year</span><span class="hidden inline-on-nt-480 ">y</span> ago</span></span>
</div>
</div>
<div class="share-bar-placeholder">
<div class="share-bar-holder main-content-vote-enabled">
<div class="share-bar-wrapper">
<div class="bar-title ">Chap Mei Dinosaurs</div>
<div class="share-bar">
<span class="hits"><span class="hide-on-nt-480 hits-full">627</span><span class="hidden inline-on-nt-480 hits-minimal">627</span></span>
<a class="dsk-small" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dinosaurhome.com%2Fchap-mei-dinosaurs-14768.html"><span ga-mes="bar:facebook" class="button-small icon-facebook w-text"></span></a>
<a class="dsk-small" target="_blank" href="https://twitter.com/intent/tweet?text=Chap%20Mei%20Dinosaurs&via=dnsrhome&url=https%3A%2F%2Fwww.dinosaurhome.com%2Fchap-mei-dinosaurs-14768.html"><span ga-mes="bar:twitter" class="button-small icon-twitter w-text"></span></a>
<span class="drop-wrap" share-url='.' ga-mes-prefix='bar'><span class="drop-control button-small icon-redo2"></span><div class="drop-area"></div></span>	</div>
</div>
</div>
</div>
<div class="post-entry main-inner-block">
<p>Chap Mei is a Hong Kong toy company that has produced numerous series of dinosaur toys over the years. I happen to own quite a few Chap Mei dinosaurs, and I thought that I would share photos of some of my collection. Although these came in sets with human figures, vehicles, and various accessories, I have chosen to only feature the dinosaur figures themselves. The Chap Mei dinosaurs are some of my all time favorites and hold a nostalgic place in my heart. What they lack in accuracy they make up with stylized designs and vibrant color schemes.</p>
<p><strong>Dino Valley series (2005)</strong></p>
<p>Amargasaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6580-1wysr6ext9_v_1486513827.jpg" alt="IMG_6580-1wysr6ext9.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6580-1wysr6ext9_v_1517457696.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6580-1wysr6ext9_v_1517457697.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6580-1wysr6ext9_v_1517457697.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6580-1wysr6ext9_v_1517457697.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Baby Styracosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6583-hw1dlhwsdv_v_1486513930.jpg" alt="IMG_6583-hw1dlhwsdv.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6583-hw1dlhwsdv_v_1517457697.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6583-hw1dlhwsdv_v_1517457698.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6583-hw1dlhwsdv_v_1517457698.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6583-hw1dlhwsdv_v_1517457698.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Ankylosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6589-k5ea4s6wb0_v_1486514032.jpg" alt="IMG_6589-k5ea4s6wb0.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6589-k5ea4s6wb0_v_1517457698.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6589-k5ea4s6wb0_v_1517457698.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6589-k5ea4s6wb0_v_1517457699.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6589-k5ea4s6wb0_v_1517457699.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Talarurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6586-rjegsypuqr_v_1486514318.jpg" alt="IMG_6586-rjegsypuqr.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6586-rjegsypuqr_v_1517457699.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6586-rjegsypuqr_v_1517457699.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6586-rjegsypuqr_v_1517457700.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6586-rjegsypuqr_v_1517457700.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Dragonosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6593-88aojnja2a_v_1486514398.jpg" alt="IMG_6593-88aojnja2a.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6593-88aojnja2a_v_1517457700.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6593-88aojnja2a_v_1517457701.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6593-88aojnja2a_v_1517457701.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6593-88aojnja2a_v_1517457701.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Dilophosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6596-wv3sk3k5e0_v_1486514481.jpg" alt="IMG_6596-wv3sk3k5e0.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6596-wv3sk3k5e0_v_1517457701.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6596-wv3sk3k5e0_v_1517457702.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6596-wv3sk3k5e0_v_1517457702.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6596-wv3sk3k5e0_v_1517457702.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Baby Tyrannosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6599-5d6ck4n8m0_v_1486514563.jpg" alt="IMG_6599-5d6ck4n8m0.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6599-5d6ck4n8m0_v_1517457702.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6599-5d6ck4n8m0_v_1517457703.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6599-5d6ck4n8m0_v_1517457703.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6599-5d6ck4n8m0_v_1517457703.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Plesiosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6632-g2fhroaqbt_v_1486514655.jpg" alt="IMG_6632-g2fhroaqbt.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6632-g2fhroaqbt_v_1517457703.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6632-g2fhroaqbt_v_1517457703.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6632-g2fhroaqbt_v_1517457704.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6632-g2fhroaqbt_v_1517457704.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Pterodactylus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6605-84zqoby0gy_v_1486514757.jpg" alt="IMG_6605-84zqoby0gy.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6605-84zqoby0gy_v_1517457704.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6605-84zqoby0gy_v_1517457704.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6605-84zqoby0gy_v_1517457705.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6605-84zqoby0gy_v_1517457705.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Stegosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6611-tf2wisrw3j_v_1486514837.jpg" alt="IMG_6611-tf2wisrw3j.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6611-tf2wisrw3j_v_1517457705.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6611-tf2wisrw3j_v_1517457705.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6611-tf2wisrw3j_v_1517457705.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6611-tf2wisrw3j_v_1517457706.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Tyrannosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6623-5ajv28zgoa_v_1486514881.jpg" alt="IMG_6623-5ajv28zgoa.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6623-5ajv28zgoa_v_1517457706.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6623-5ajv28zgoa_v_1517457706.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6623-5ajv28zgoa_v_1517457707.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6623-5ajv28zgoa_v_1517457707.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p><strong><strong>Ice Quest: Arctic Rescue series (2005)</strong></strong></p>
<p>Smilodon</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/Smilodon-lbfc2gew7m_v_1486678440.jpg" alt="Smilodon-lbfc2gew7m.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/Smilodon-lbfc2gew7m_v_1517457707.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/Smilodon-lbfc2gew7m_v_1517457707.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/Smilodon-lbfc2gew7m_v_1517457708.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/Smilodon-lbfc2gew7m_v_1517457708.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p><strong><strong>Dino Valley 2 series (2006)</strong></strong></p>
<p>Therizinosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6617-44q8x32apt_v_1486515183.jpg" alt="IMG_6617-44q8x32apt.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6617-44q8x32apt_v_1517457708.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6617-44q8x32apt_v_1517457709.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6617-44q8x32apt_v_1517457709.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6617-44q8x32apt_v_1517457709.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Suchomimus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6627-3hk2anwjop_v_1486515235.jpg" alt="IMG_6627-3hk2anwjop.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6627-3hk2anwjop_v_1517457709.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6627-3hk2anwjop_v_1517457710.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6627-3hk2anwjop_v_1517457710.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6627-3hk2anwjop_v_1517457710.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p>Styracosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6614-snx8bhdt54_v_1486515297.jpg" alt="IMG_6614-snx8bhdt54.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6614-snx8bhdt54_v_1517457710.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6614-snx8bhdt54_v_1517457711.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6614-snx8bhdt54_v_1517457711.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6614-snx8bhdt54_v_1517457711.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/></p>
<p><strong><strong>Stone Age Dinosaurs series (2008)</strong></strong></p>
<p>Therizinosaurus</p>
<p><img src="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/IMG_6620-wuk90wtui3_v_1486515361.jpg" alt="IMG_6620-wuk90wtui3.jpg" srcset="https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/1242w/IMG_6620-wuk90wtui3_v_1517457712.jpg 1242w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/828w/IMG_6620-wuk90wtui3_v_1517457712.jpg 828w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/625w/IMG_6620-wuk90wtui3_v_1517457712.jpg 625w, https://d29jd5m3t61t9.cloudfront.net/dinosaurhome.com/components/com_mojo/wp-content/uploads/2017/02/414w/IMG_6620-wuk90wtui3_v_1517457712.jpg 414w" sizes="(max-width: 30em) 380px, (max-width: 65em) 382px, 660px"/> </p>
<p class="hide-on-print blog-comment-request">
So... what do you think? <a href='chap-mei-dinosaurs-14768.html#add_comments'>Please leave me a comment</a>.
</p>
</div>
<div class="mojo_bp_e">
<div class="moduletable_simple_title">
<div id="mod_la_110_block">
<h3>
This Might Interest You	</h3>
<div class="latest_activity">	<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_1kow0x_14707"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="dinosaur-toys-in-action-14707.html">Dinosaur Toys in Action</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_11856"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="dinosaurs-10-million-years-older-than-thought-118562.html">Dinosaurs 10 million years older than thought ?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_9405"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="1991-phoenix-toys-inc-dinosaur-toy-94052.html">1991 Phoenix Toys inc Dinosaur Toy</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_19852"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="were-volcanoes-really-everywhere-during-the-dinosaurs-time-..as-stereotyp...-198522.html">Were volcanoes really everywhere during the dinosaurs&#039; time?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_12250"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="acamaro-figures-122502.html">Acamaro Figures?!!</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_20079"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="who-is-the-king-of-the-dinosaurs-you-think-t.rex-or-another-dinosaur-200792.html">Who is the king of the dinosaurs you think t.Rex or another dinosaur</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_36544"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="favorite-dinosaurs-and-dinosaurs-only-who-are-your-all-time-favorite-din...-36544.html">Favorite Dinosaurs (And Dinosaurs Only) Who are your all time favorite Din...</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_8296"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="did-the-size-of-dinosaurs-change-over-time-82964.html">Did the Size of Dinosaurs Change over Time?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_37195"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="dinosaurs-vs.-dinosaurs-who-would-win-which-dinosaurs-do-you-think-w...-37195.html">DINOSAURS VS. DINOSAURS WHO WOULD WIN?!!!!! Which Dinosaurs do you think w...</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_38697"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="dinosaurs-and-animals-death-if-the-dinosaur-or-animal-die-from-being-kille...-38697.html">Dinosaurs and animals death If the dinosaur or animal die from being kille...</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_32958"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="you-can-journey-back-to-only-1-place-in-time-where-do-you-go-32958.html">You Can Journey Back To Only 1 Place In Time - Where Do You Go?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_70371"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="how-have-dinosaurs-changed-over-time-in-the-dinosaurs-age-to-up-till-now-70371.html">How have dinosaurs changed over time in the dinosaurs age to up till now</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_1kow0x_14805"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="dinosaurs-of-iowa-14805.html">Dinosaurs of Iowa</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_64794"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="dinosaur-toys-64794.html">Dinosaur Toys</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_1kow0x_66244"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="can-you-match-the-dinosaur-to-the-record-that-it-holds-dinosaurs-a.-sau...-66244.html">Can you match the dinosaur to the &quot;record&quot; that it holds? Dinosaurs: A. Sau...</a></span></h5></div>
</div>
</div>
<div class="clr"></div>
</div>	</div>
</div>
<a name="linkback_comments"></a>
<div id="mojo_comments">
<a name="comments"></a>
<h3>13 Comments:</h3>
<ul class="commentlist undecorated main-inner-block">
<li class="altreply">
<span class="link-target" id="comment-11158"></span>
<div class="comment-block">
<cite>Vale</cite>:
<span class="commentmetadata">
</span>
<span class="comment">Nice collection, I like the colors and features</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11159"></span>
<div class="comment-block">
<cite>JMD</cite>:
<span class="commentmetadata">
</span>
<span class="comment">I believe I have the Ornitholestes (&quot;Dragonosaurus&quot;) and the Plesiosaurus for sure. The Suchomimus seems to have the same shape as mine, but it&#8217;s a different color. Does it have a movable jaw and limbs like mine does?</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11160"></span>
<div class="comment-block">
<cite>Carnoferox</cite>:
<span class="commentmetadata">
</span>
<span class="comment"><p>Yes, my Suchomimus also has a movable jaw and arm. I&#8217;m sure yours is just a repaint of the same model as mine; the Chap Mei dinosaurs have lots of color variations.</p></span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11161"></span>
<div class="comment-block">
<cite>Souppedy Doup</cite>:
<span class="commentmetadata">
</span>
<span class="comment">Good thing you don&#8217;t have the Chap Mei Parasaurolophus, that thing is hideous.</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11163"></span>
<div class="comment-block">
<cite>Fossil Huntress</cite>:
<span class="commentmetadata">
</span>
<span class="comment">These are awesome! Thank you so much for sharing. I&#8217;ve often thought that if you took some great dinosaur toys into your garden and took photos with Kale, you could recreate a great Jurassic scene. <br/>Appreciate you sharing some of your world with us.<br/>Fossil Huntress ; )</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11164"></span>
<div class="comment-block">
<cite>JMD</cite>:
<span class="commentmetadata">
</span>
<span class="comment">@Fossil Huntress:<br/>I used to do something like that a lot- I&#8217;d take my dinosaur toys outside and act out a scene from the Mesozoic using scenery outside.</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11165"></span>
<div class="comment-block">
<cite>Dinosaurus rex</cite>:
<span class="commentmetadata">
</span>
<span class="comment">I definetly had that baby tyrannosaurus. Back then I liked dinosaur toys that were less stiff and more posable, so I don&#8217;t think I used it too much.</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11168"></span>
<div class="comment-block">
<cite>Carnoferox</cite>:
<span class="commentmetadata">
</span>
<span class="comment">@Souppedy Doup<br/>I think you&#8217;re talking about the Parasaurolophus from the Dino Quest series (2001). That Parasaurolophus was pretty bad, looking more like a theropod with a Parasaurolophus crest. The Dino Quest line as a whole was pretty rough, and the later series greatly improved their models. The Dino Valley 2 series had a much better Parasaurolophus.</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11170"></span>
<div class="comment-block">
<cite>Evamimous Raptor</cite>:
<span class="commentmetadata">
</span>
<span class="comment">I can still locate my suchomimus, which I bought for fun. It was actually fairly interesting.</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11171"></span>
<div class="comment-block">
<cite>Carnoferox</cite>:
<span class="commentmetadata">
</span>
<span class="comment">What color is your Suchomimus?</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11177"></span>
<div class="comment-block">
<cite>Evamimous Raptor</cite>:
<span class="commentmetadata">
</span>
<span class="comment">Same coloration</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11733"></span>
<div class="comment-block">
<cite>Spinopharoah</cite>:
<span class="commentmetadata">
</span>
<span class="comment">The Therizinosaurus’ need to be killed with fire.<br/>HOLY COW! They actually had Talarurus!</span>
</div>
</li>
<li class="altreply">
<span class="link-target" id="comment-11737"></span>
<div class="comment-block">
<cite>Carnoferox</cite>:
<span class="commentmetadata">
</span>
<span class="comment"><p>I actually like the Therizinosaurus considering its color scheme and sculpt are some of the best of the series, and the fact that it was the first toy of the creature produced (quite awhile before Schleich&#8217;s version).</p></span>
</div>
</li>
</ul>
<a name="add_comments"></a>
<div id="mojo_commentForm">
<form action="components/com_mojo/wp-comments-post.php" method="post" id="commentform" class="rounded_corners_lp_heavy">
<h3 id="respond">Add Your Own Comment:</h3>
<p>
<textarea class="comment" name="comment" id="comment" cols="65" rows="10" tabindex="4" required="required" x-invalid-message="Please enter a comment"></textarea>
</p>
<p>
<label for="author"><span>Display name *</span></label>
<input class="comment" type="text" x-autocompletetype="nickname" name="author" id="author" value="" size="22" tabindex="1" required="required" x-invalid-message="Please enter a display name"/>
</p>
<p>
<label for="email"><span>eMail (will not be published) *</span></label>
<input class="comment" type="email" x-autocompletetype="email" name="email" id="email" value="" size="22" tabindex="2" required="required" pattern="^\w([\w\.\-]+)@(\b([a-zA-Z0-9][\w\-]{0,62}\.(?<=[a-zA-Z0-9]\.))+(a(c(|\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so))|d|e|f|g|i|l|n|o|q|r|sia|u|w|x|z)|b(a|b|d|e|f|g|h|i(|z)|j|m|n|o|r|s|t|v|w|y|z)|c(a|c|d|f|g|h|i|k|l|m|n|o(|\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so)|m|op)|r|s|u|v|x|y|z)|d(d|j|k|m|o|z)|e(c|du|du\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so)|e|g|h|r|s|t|u)|f(i|j|k|m|o|r)|g(a|b|d|e|f|g|h|i|l|m|n|ov\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so)|p|q|r|s|t|u|w|y)|h(k|m|n|r|t|u)|i(d|nfo|nt|o|q|r)|j(e|m|o|obs|p)|k(e|g|h|i|m|n|p|r|w|y|z)|l(a|b|c|i|k|r|s|t|u|v|y)|m(a|g|h|k|l|m|n|o(|bi)|p|q|r|s|t|u|v|w|x|z)|n(a(|me)|c|e(|t|t\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so))|f|g|i|l|p|r|u|z)|o(m|rg|rg\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so))|p(a|e|f|g|h|k|l|m|n|r(|o)|s|t|w|y)|qa|r(e|o|s|u|w)|s(a|b|c|d|e|g|h|i|j|k|l|m|r|s|t|u|v|x|y|z)|t(c|d|el|f|g|h|j|k|l|m|n|o|p|r(|avel)|t|v|w|z)|u(a|g|k|s|y|z)|v(a|c|e|g|i|n|u)|w(f|s)|xxx|y(e|t|u)|z(a|m|w))\b|live.in)$" x-invalid-message="Please enter a valid email address."/>
</p>
<input type="hidden" name="comment_ref" value="9684b31d118f2c155fbd2bbeb5e11b05190aa10ebf3749f21e4cd94ea5c9a8d1">
<p>
<input type="checkbox" name="subscribe" id="subscribe" value="subscribe" checked>
<label for="subscribe"><span>Get notifications</span></label>
</p>
<p>
<input class="button" name="submit" type="submit" id="submit" tabindex="5" value="Submit"/>
<input type="hidden" name="comment_post_ID" value="14768"/>
</p>
<div class="submit-terms">By clicking 'Submit' you agree to the <a target='_blank' href='terms/' class='nowrap'>Site Terms</a></div>	</form>
</div>
</div>
</div>
<div class="navigation">
<span class="alignleft"></span>
<span class="alignright"></span>
</div>
</div>
</div>
</div>
<div id="right-col">
<div class="padding"><div class="moduletable_ main-ask-box-wrap">
<div class="main-ask-box ">
<form class="rounded_corners_lp_heavy" enctype="multipart/form-data" name="postform_quick" method="post" id="fb_quick_topic" action="questions-answers/post.html?do=reply&amp;guesscat=1&amp;ref=qcktpcg">
<div class="explain">
<h3 class="title">Ask Your Question</h3>
</div>
<div class="input_area">
<input type="hidden" id="fb_post_subject" name="subject" value=""/>
<input type="hidden" id="fb_post_cookie" name="fb_post_cookie" value="e1954704be1ffdd51a84f6ffc1adc1fe"/>
<input type="hidden" value="0" name="parentid"/>
<input type="hidden" value="empty" name="contentURL"/>
<input type="hidden" value="Guest" name="fb_authorname" id="fb_post_author"/>
<input type="hidden" name="templatePath" value="https://www.dinosaurhome.com/components/com_fireboard/template/default"/>
<div class="attach-images-in-textarea-block">
<textarea required='required' x-invalid-message='For better and faster answers, please write your question in more details.' x-minlength='60' name='message' class='rounded_corners_lp_light' onfocus-tip='Please add extra details and photos.'></textarea>
<div class="attach-images-in-textarea-wrap">
<div class="attach-images-in-textarea-label">
<a href="javascript:void(0)" onclick="javascript:toggleOpenCloseSection(document.getElementById('b58f'),document.getElementById('toggle_icon_b58f'),null,null,this);" class="control">Attach Photos</a>	</div>
</div>
</div>
<div id="b58f" class="hidden attach-images-in-textarea-files">
<input type="file" class="file rounded_corners_lp_light" name="attachimage" accept="image/*"/><br/>
<input type="file" class="file" name="attachimage2" accept="image/*"/>
<input type="file" class="file" name="attachimage3" accept="image/*"/>
<input type="file" class="file" name="attachimage4" accept="image/*"/>
</div>
<div id="mod_fb_posts_extra_fields">
<div id="subscribe_guest">
<div>Email to be Notified (Optional):</div>
<input type="email" class="rounded_corners_lp_light" name="email" size="" maxlength="150" value="" x-autocompletetype="email" pattern="^\w([\w\.\-]+)@(\b([a-zA-Z0-9][\w\-]{0,62}\.(?<=[a-zA-Z0-9]\.))+(a(c(|\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so))|d|e|f|g|i|l|n|o|q|r|sia|u|w|x|z)|b(a|b|d|e|f|g|h|i(|z)|j|m|n|o|r|s|t|v|w|y|z)|c(a|c|d|f|g|h|i|k|l|m|n|o(|\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so)|m|op)|r|s|u|v|x|y|z)|d(d|j|k|m|o|z)|e(c|du|du\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so)|e|g|h|r|s|t|u)|f(i|j|k|m|o|r)|g(a|b|d|e|f|g|h|i|l|m|n|ov\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so)|p|q|r|s|t|u|w|y)|h(k|m|n|r|t|u)|i(d|nfo|nt|o|q|r)|j(e|m|o|obs|p)|k(e|g|h|i|m|n|p|r|w|y|z)|l(a|b|c|i|k|r|s|t|u|v|y)|m(a|g|h|k|l|m|n|o(|bi)|p|q|r|s|t|u|v|w|x|z)|n(a(|me)|c|e(|t|t\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so))|f|g|i|l|p|r|u|z)|o(m|rg|rg\.(am|as|at|de|my|ie|il|im|in|is|it|mc|md|me|no|sn|so))|p(a|e|f|g|h|k|l|m|n|r(|o)|s|t|w|y)|qa|r(e|o|s|u|w)|s(a|b|c|d|e|g|h|i|j|k|l|m|r|s|t|u|v|x|y|z)|t(c|d|el|f|g|h|j|k|l|m|n|o|p|r(|avel)|t|v|w|z)|u(a|g|k|s|y|z)|v(a|c|e|g|i|n|u)|w(f|s)|xxx|y(e|t|u)|z(a|m|w))\b|live.in)$" x-invalid-message="Please enter a valid email address."/>
</div>
<div class="experts_assistance">
<input type="checkbox" value="experts" name="post_type" id="choose_experts_checkbox">
<span class="choose_experts_checkbox" onclick="switchCheckbox(document.postform_quick.post_type)">
Get a paid assistance	</span>
<img src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/help.png" class="icon" alt="[?]" onclick="showTooltip(this, '<b><span>Why pay when the forums are free?</span></b>&lt;ul id=\&quot;list_experts_benefit\&quot;&gt;&lt;li&gt;Get timely answers from the &lt;b&gt;Top Experts!&lt;/b&gt;&lt;/li&gt;&lt;li&gt;Keep your question &lt;b&gt;Private&lt;/b&gt;.&lt;/li&gt;&lt;li&gt;Get satisfied &lt;b&gt;or your money back&lt;/b&gt;&lt;span class=\&quot;hide-on-demand\&quot;&gt; guaranteed&lt;/span&gt;! &lt;/li&gt;&lt;/ul&gt;', {&quot;width&quot;:300,&quot;align&quot;:&quot;left&quot;,&quot;valign&quot;:&quot;above&quot;});" onmouseover="if (isIOS()) return; showTooltip(this, '<b><span>Why pay when the forums are free?</span></b>&lt;ul id=\&quot;list_experts_benefit\&quot;&gt;&lt;li&gt;Get timely answers from the &lt;b&gt;Top Experts!&lt;/b&gt;&lt;/li&gt;&lt;li&gt;Keep your question &lt;b&gt;Private&lt;/b&gt;.&lt;/li&gt;&lt;li&gt;Get satisfied &lt;b&gt;or your money back&lt;/b&gt;&lt;span class=\&quot;hide-on-demand\&quot;&gt; guaranteed&lt;/span&gt;! &lt;/li&gt;&lt;/ul&gt;', {&quot;width&quot;:300,&quot;align&quot;:&quot;left&quot;,&quot;valign&quot;:&quot;above&quot;});;" onmouseout="hideDropArea();"/>	</div>
</div>
<div id="fb_post_submit">
<input type="submit" class="button button-yellow button-medium" value="Submit"/>
<div class="submit-terms">By clicking 'Submit' you agree to the <a target='_blank' href='terms/' class='nowrap'>Site Terms</a></div>	</div>
</div>
</form>
</div>	</div>
<div class="moduletable">
<div class="ad-wrap adsense wrap-responsive wrap-rectangle wrap-r1">
<span class="ad-title ad-title-responsive"><span class="sponsored-links-h3"></span></span>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-0574877161340944" data-ad-slot="4204917914" data-ad-format="rectangle"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>
<div class="ad-end"></div>	</div>
<div class="moduletable">
<div id="mod_la_137_block">
<h3>
This Might Interest You	</h3>
<div class="latest_activity">	<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_w28k4_474"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="radioactivity-in-dinosaur-fossils-did-radiation-kill-the-dinosaurs-474.html">Radioactivity in Dinosaur Fossils - Did radiation kill the dinosaurs?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_w28k4_14301"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="new-series-featuring-dinosaurs-in-the-old-west-14301.html">New Series Featuring Dinosaurs in the Old West!</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_w28k4_1015"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="top-10-herbivorous-dinosaurs-1-my-favourite-dinosaur-triceratops-1015.html">Top 10 Herbivorous Dinosaurs : 1 - My Favourite Dinosaur, Triceratops</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_w28k4_443"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="ocean-going-dinosaurs-the-biggest-dinosaur-443.html">Ocean-going Dinosaurs, the biggest Dinosaur</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_w28k4_11419"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="how-did-dinosaurs-change-over-time-in-the-mesozoic-era-114194.html">How did dinosaurs change over time in the Mesozoic Era?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xforum_post.png.pagespeed.ic.CvnPmwlGwF.png" title="Forum Post" name="forum_w28k4_10951"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="what-time-did-the-megalodon-live-with-the-dinosaurs-109514.html">What time did the megalodon live with the dinosaurs</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_w28k4_1723"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="how-did-dinosaurs-change-over-time-in-the-mesozoic-era-1723.html">How did dinosaurs change over time in the Mesozoic Era?</a></span></h5></div>
</div>
<div class="no_snippet clr">
<img class="latest_activity_icon icon" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/images/xblog_post.png.pagespeed.ic.cyxQhyUvf2.png" title="Blog Post" name="blog_post_w28k4_1915"/>	<div class="entry_title"><h5><span class="mod_fblatest_subject"><a href="my-top-10-favorites-dinosaurs-with-explanations-outdated-1915.html">My Top 10 Favorites Dinosaurs (with explanations) OUTDATED!!</a></span></h5></div>
</div>
</div>
<div class="clr"></div>
</div>	</div></div>
</div>
<div class="clr"></div>
</div>
</div>
<div id="main-bottom">
<div class="wrapper">	<div class="moduletable">
<div id="terms" class="quiet smaller">
By entering this site you declare
you read and agreed to its <a href="terms/" class="underlined">Terms, Rules &amp; Privacy</a>
and you understand that your use of the site's content is made at your own risk and responsibility.
Copyright &copy; 2006 - 2018 Dinosaur Home</div>	</div>
</div>
</div>
<script type="text/javascript">var bb3_smilies_type=15;</script><script type="text/javascript">var ej_hook=["2af6b143fe1065e9f22a7f834f6c586a","071ad305baab123e550713860d1616b5","64fceea21d8ad4138fabaa7cab820502","d0a3dae47ea8a289c13bc0364f08eb22","dbb5a8ebcadf812be3776fb87bd01356","0baa8405a2786b8970d0c3133cfb93ab","e4b5a49f35b609b29edad2e26401cbf7","6e5284d37edda32862bda43fcd651f99","33adca18bc94d62273ab63cddf5f7a21","5c2a43a682dd9aceb3eee8d818af1d85","bf8f6f58951389b25228544c03e2884f","e4a148d33e53cf98a6715b6eefcdd763","b198301f219566564b593e585682009a","4f967be8ccce7dad966a1d2a5c9d769e","507d7ebf398d2e72dda3ad2e6fcdb801","e1954704be1ffdd51a84f6ffc1adc1fe","b583a0d7bada7c1a5e82281a68087045","d6d602a6528a4b737695046443514d00","9e37374c1ac1f91032f2504a0f0c6322","ba3553449221c8c0ff309c7f1fd80fcf"];</script><script type="text/javascript">var deferredCSS=deferredCSS||[];deferredCSS.push({"u":"https:\/\/d29jd5m3t61t9.cloudfront.net\/static\/templates\/rt_fire\/fonts\/icomoon.normal.deffered_v_1509880363.css","c":"iconx-load-css"});</script><script type="text/javascript" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/js/sharebar_v_1512834668.js.pagespeed.jm.i2wiW30DbP.js" async></script><script type="text/javascript">var gaOptions={"selector":"#commentform input[type='submit']","event":"click","cat":"comments","act":"submit","label":"post-page"}</script><script type="text/javascript" src="https://d29jd5m3t61t9.cloudfront.net/static/includes/kikuta/js/submit_helpers_v_1514126683.js.pagespeed.jm.LdgG69t5VK.js" async></script><script type="text/javascript">var askBoxParams={"customTip":"We need those details in order to assist you faster and give you a more accurate answer.","maxSubjectLength":75,"coo":"9684b31d118f2c155fbd2bbeb5e11b05190aa10ebf3749f21e4cd94ea5c9a8d1"};</script><script type="text/javascript" src="https://d29jd5m3t61t9.cloudfront.net/static/includes/js/overlib.all.mini_v_1501069214.js.pagespeed.jm.7xNq4VDvj0.js" async></script><script type="text/javascript" src="https://d29jd5m3t61t9.cloudfront.net/static/templates/rt_fire/js/template_support_body_end_v_1511168727.js.pagespeed.jm.ODYYMYiX2d.js" async></script><script type="text/javascript" async>//<![CDATA[
(function(window,document){function preparePrint(){var printStyle=".qr-code:before { content:url(https://chart.googleapis.com/chart?cht=qr&chs=75x75&choe=UTF-8&chld=H&chl="+window.location.href+");}"+".view-current-url:before { content:'"+window.location.href+"' }";addStyle(printStyle);subscribeElementsToEvent(".drop-wrap[share-url] .drop-control","click",function(){forceLoadClass("qr-code");});}window.addEventListener('load',preparePrint);})(window,document);
//]]></script><script type="text/javascript">overlib_pagedefaults_params=['VAUTO'];</script><script type="text/javascript" src="https://d29jd5m3t61t9.cloudfront.net/static/includes/kikuta/js/base_helpers_v_1511259926.js.pagespeed.jm.Fg-pmnVnHM.js" async></script></body>
</html>